AnsweredAssumed Answered

How to recover T1042D4RDB after flash rootfs corruption

Question asked by Sjain Jain on Oct 31, 2016
Latest reply on Nov 2, 2016 by ufedor

I have a Freescale T1042D4RDB-64bit eval kit. I was trying to program the NOR flash with JFFS2 format rootfs. Basically I tried the steps mentioned in Section 8.8.1 of QorIQ-SDK-2.0-IC-Rev0.pdf. First I copied JFFS2 image into flash through u-boot and then went on to do the steps to test NOR JFFS2 support to boot up kernel and mount JFFS2 filesystem. Once the Linux came up, I tried to mount JFFS2 on /dev/mtdblock0. It gave me error "jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00260054: 0xffff instead".

 

At this instance I did a "reboot" on linux shell. The console output got stuck and it never recovered. I have done power cycle after that but I don't see any output on the console terminal. I can hear fans, and see system LEDs, but the console terminal is totally blank. Is there a way I can recover the device?

Outcomes