AnsweredAssumed Answered

I am attempting to use a TWR-KV58F220M tower board with SDK_2.0_TWR-KV5. I build the freertos_uart example project with no error on IAR 7.60.2. When I attempt “Download and Debug” I always get two and sometimes three errors reported in the Debug Log, all

Question asked by Larry Hill on Oct 18, 2016
Latest reply on Oct 18, 2016 by Hui_Ma

I am attempting to use a TWR-KV58F220M tower board with SDK_2.0_TWR-KV5. I build the freertos_uart example project with no error on IAR 7.60.2. When I attempt “Download and Debug” I always get two and sometimes three errors reported in the Debug Log, all not fatal.  The two I always get are:

Tue Oct 18, 2016 17:33:40: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.6\arm\config\debugger\NXP\KV5x.dmac(29,13): Error: Operation error. 

And:

Tue Oct 18, 2016 17:33:43: C:\Program Files (x86)\IAR Systems\Embedded Workbench 7.6\arm\config\debugger\NXP\KV5x.dmac(29,13): Error: Operation error. 

The one I sometimes get is:

Tue Oct 18, 2016 14:33:25: Verification error at 0x10000000: mem =0xFF, file = 0x00.

When I open the memory window in the debugger I see the file value x00  displayed, as I should. So apparently it was the read operation by the debugger when verifying that failed. The value read for the error message varies from incident to incident and it is always location 0x10000000.

When I go to main and run, the program appears to behave as it should.

I build and ran your example code without making any changes to it.  

Why am I seeing this and what do I need to do to correct it?

Outcomes