AnsweredAssumed Answered

PE Multilink issue when install and debug with S32

Question asked by Yuehe Deng on Oct 16, 2016
Latest reply on Oct 24, 2016 by Yuehe Deng

Hi,

 

   My computer is win7-64bit. When I install s32 V1.0 for power pc, the last step is PE multilink driver installing, and it came up an error pop-up. The msg is shown as below.


WDREG utility v11.7.0. Build Oct 26 2014 09:21:13
Log from Fri Oct 14 09:19:00 2016

Command line: d:\Freescale\S32_Power_v1.0\Drivers\PnE\Drivers_12_2_0\windriver\wdreg_gui.exe -inf d:\Freescale\S32_Power_v1.0\Drivers\PnE\Drivers_12_2_0\windriver\windrvr6.inf -log d:\Freescale\S32_Power_v1.0\Drivers\PnE\Drivers_12_2_0\windriver\windrvr6_install.log install

Processing HWID *WINDRVR6
Trying to create virtual device
Installing a signed driver package for *WINDRVR6
Error: Failed to install the INF file (d:\Freescale\S32_Power_v1.0\Drivers\PnE\Drivers_12_2_0\windriver\windrvr6.inf)

Please verify your driver is signed or disable Windows driver signature enforcement.

LOG ok: 1, ENTER: DriverPackageInstallA
LOG ok: 1, ENTER: DriverPackageInstallW
LOG ok: 1, Looking for Model Section [DeviceList.NTamd64]...
LOG ok: 1, Installing INF file 'd:\Freescale\S32_Power_v1.0\Drivers\PnE\Drivers_12_2_0\windriver\windrvr6.inf' (Plug and Play).
LOG ok: 1, Looking for Model Section [DeviceList.NTamd64]...
LOG ok: 1, Installing devices with Id "*WINDRVR6" using INF "C:\Windows\System32\DriverStore\FileRepository\windrvr6.inf_amd64_neutral_cf1867c43a919695\windrvr6.inf".
LOG ok: 1, ENTER UpdateDriverForPlugAndPlayDevices...
LOG ERROR(3): error e0000234, RETURN UpdateDriverForPlugAndPlayDevices.
LOG ERROR(3): error e0000234, Installation failed.
LOG ERROR(3): error e0000234, PnP Install failed.
LOG ok: 1, Attempting to rollback ...
LOG ok: 1, No devices to rollback
LOG ok: 1, RETURN: DriverPackageInstallW (0xE0000234)
LOG ok: 1, RETURN: DriverPackageInstallA (0xE0000234)
difx_install_preinstall_inf: err e0000234, last event 3, last error e0000234. ERROR_DRIVER_NONNATIVE
Error: Failed trying to install the driver
STATUS_FAILURE

 

Luckily, I still can install the PE multilink driver via computer device manager.

 

But when I tried to debug my project with S32, it still can't recognize Multilink. Every time I click refresh, then pegdbserver_power_console.exe stops working.

 

 

Could anyone give me a hand about this issue?

Outcomes