AnsweredAssumed Answered

LPCXpresso installation for LDAP (non-local) user accounts

Question asked by Timo Räty on Oct 13, 2016
Latest reply on Oct 18, 2016 by LPCX presso support

Hello,

 

Recently I needed to install LPCXpresso on several Linux computers.

The target was to get a fully functional system for different users of the computer.

However, this seems to fail miserably because the user accounts are stored in LDAP.

This means that the account data is not in the usual (e.g. /etc/passwd) format and it is

always fetched from LDAP (ie from network service).

When installing with such a user account the installation fails, complaining something

about "id user". I suspect that this is due to the "id" command returning data in format

not understood by the installer - or returning more(?) than the installer understands.

So, the installation with LDAP account does not work - at all in my case.

 

Next, we tried creating local account and installing using that. This works for installing

but fails for LDAP users when trying to run the LPCXpresso (from /usr/local/lpcxpresso...)

With this one the problem seems to be non-local user accounts again but the error

is manifested differently: the LPCXpresso IDE fails to start because the user does not

have enough access rights in the /usr/local/lpcxpresso... directory. Frankly, the user

should not have write access therein at all - but allowing that will enable the IDE for

one user, while others will fail. Again, the problem seems to be with LDAP (vs local

accounts), in this case most likely due to not understanding where the home folder

for (LDAP based) user is. As the home directory is somehow not found, the IDE tries

to write to (default location?) under /usr/local/lpcxpresso... and that is (naturally) owned

by "root" account.

 

As this was tried in a setup where I do not myself have "root" account rights I cannot say

whether there is issues coming from the system itself. However, considering that the

Installation executable really complains about the LDAP user starting the installation, I would

say there is something wrong in the installation media.

 

So, far the only ways we get this working are:

* using local account only: both for installation and running the IDE

* installing into user directory by copying an installation

 

Neither of these is a good solution. Both require considerable amount of additional work to get the IDE running properly.

 

This system setup is used temporarily for research purposes and we need to have efficient way of deploying the system.

 

A working solution would be really appreciated, thanks!

 

Timo

Outcomes