AnsweredAssumed Answered

TWR-K65F180M non-functional USB

Question asked by Bart Rijvers on Oct 12, 2016
Latest reply on Oct 13, 2016 by Bart Rijvers

We've ordered a TWR-K65F180M board to evaluate the USB mass storage speed for a project we need to do. We already have this evaluated on a K64F using the SD card FreeRTOS example and found the speed insufficient.

Loading the same example from the K65F SDK 2.0 (downloaded yesterday) into the K65F board does not do anything; my Windows 7 PC does not recognize any USB device being plugged in. It even turns out that any other USB example does not register any USB device in Windows.

All jumper settings are as the board arrived and we've tested some different settings with no results.

We also tried different micro-USB cables and tried on a different Windows 7 PC, all having no result at all.

The only mod to the board was flashing a JLink debugger into the bootloader.

I'm using Kinetis Design Studio 3.2.0 with all updates installed.

I could use help urgently...

Outcomes