AnsweredAssumed Answered

No license found, error with key GPTRACE 11.0

Question asked by Christian Lemer on Oct 5, 2016

Hello,

 

I just installed CodeWarrior on a Ubuntu 14.04 machine and received a warning that an evaluation license of 15 days would be generated. However, as I tried to use the Flash Programmer tool (the cwflash.py script for gdb), this is the result that I got:

 

(gdb) source ../../gdb_extensions/flash/cwflash.py       
Starting flash programmer services...
Starting local server...
Successfully started gdb server 127.0.0.1:45008.
Set gdb remote timeout to 7200
Connecting to target...
Using LS1012A SoC
Using CMSIS-DAP
Using jtag speed 6000
Connecting to probe...
GTA: license checkout failed.
connection failed
Target connection failed. Please re-check the settings.

Processor: LS1012A
Probe: //
Additional error details:
[GTA: license checkout failed]

Closing debugger server...
Error: fail to start flash programming services.

 

When I run the eclipse version of CodeWarrior directly through fsl_eclipse.sh, I get a window with error messages about license keys:

 

Eclipse error window about missing license files

 

What should I do to get an evaluation license ?

 

Thanks

Outcomes