AnsweredAssumed Answered

Custom Kernel Build on IMX6 Sabrelite (Ubuntu 14.04.5 LTS)

Question asked by Anuradha Ranasinghe on Oct 3, 2016
Latest reply on Oct 6, 2016 by Anuradha Ranasinghe

Hi all,

I have built a custom kernel (3.14.52 ga) and integrate it into a prebuilt (ubuntunizing) SD card image as stated in following BD post. 

https://boundarydevices.com/ubuntunizing-i-mx6-kernels/ 

 

Now I am having a trouble of getting the video output enabled from BDSL board. My primary requirement is to get the RGB port to work, but after the kernel update (everything works fine with prebuilt original ubuntu image) now even the hdmi video does not seem to work. I tried passing bootargs commands to uboot for hdmi output configuration. Here is my uboot environment print :

U-Boot 2015.07-15001-g440d481 (Oct 07 2015 - 12:30:57 -0700)
CPU: Freescale i.MX6Q rev1.2 996 MHz (running at 792 MHz)
Reset cause: POR
Board: SABRE Lite
I2C: ready
DRAM: 1 GiB
MMC: FSL_SDHC: 0, FSL_SDHC: 1
SF: Detected SST25VF016B with page size 256 Bytes, erase size 4 KiB, total 2 MiB
auto-detected panel 1280x720M@60
Display: hdmi:1280x720M@60 (1280x720)
In: serial
Out: serial
Err: serial
Net: using phy at 6
FEC [PRIME], usb_ether
Error: usb_ether address not set.
Hit any key to stop autoboot: 0
=> print
baudrate=115200
board=sabrelite
bootargs=video=mxcfb0:dev=hdmi,1280x720M@60,if=RGB24
bootcmd=for dtype in ${bootdevs}; do if itest.s "xusb" == "x${dtype}" ; then usb start ;fi; for disk in 0 1 ; do ${dtype} dev ${disk} ;load ${dtype} ${disk}:1 10008000 /6x_bootscript&& source 10008000 ; done ; done; setenv stdout serial,vga ; echo ; echo 6x_bootscript not found ; echo ; echo serial console at 115200, 8N1 ; echo ; echo details at http://boundarydevices.com/6q_bootscript ; setenv stdout serial;setenv stdin serial,usbkbd;for dtype in ${umsdevs} ; do if itest.s sata == ${dtype}; then initcmd='sata init' ;else initcmd='mmc rescan' ;fi; for disk in 0 1 ; do if $initcmd && $dtype dev $disk ; then setenv stdout serial,vga; echo expose ${dtype} ${disk} over USB; ums 0 $dtype $disk ;fi; done; done ;setenv stdout serial,vga; echo no block devices found;
bootdelay=3
bootdevs=sata mmc usb
clearenv=if sf probe || sf probe || sf probe 1 ; then sf erase 0xc0000 0x2000 && echo restored environment to factory default ; fi
cmd_hdmi=fdt set fb_hdmi status okay;fdt set fb_hdmi mode_str 1280x720M@60;
cmd_lcd=fdt set fb_lcd status disabled
cmd_lvds=fdt set fb_lvds status disabled
console=ttymxc1
cpu=6Q
dfu_alt_info=u-boot raw 0x0 0xc0000
ethact=FEC
ethaddr=00:19:b8:02:79:6c
ethprime=FEC
fdt_addr=0x13000000
fdt_high=0xffffffff
initrd_high=0xffffffff
loadaddr=0x12000000
loadsplash=if sf probe ; then sf read ${splashimage} c2000 ${splashsize} ; fi
reset_cause=1
rundfu=dfu 0 sf 0:0:25000000:0
uboot_defconfig=nitrogen6q
umsdevs=sata mmc
upgradeu=for dtype in ${bootdevs}; do for disk in 0 1 ; do ${dtype} dev ${disk} ;load ${dtype} ${disk}:1 10008000 /6x_upgrade && source 10008000 ; done ; done
usbnet_devaddr=00:19:b8:00:00:02
usbnet_hostaddr=00:19:b8:00:00:01
usbrecover=setenv ethact usb_ether; setenv ipaddr 10.0.0.2; setenv netmask 255.255.255.0; setenv serverip 10.0.0.1; setenv bootargs console=ttymxc1,115200; tftpboot 10800000 10.0.0.1:uImage-${board}-recovery&& tftpboot 12800000 10.0.0.1:uramdisk-${board}-recovery.img && bootm 10800000 12800000
Environment size: 2172/8188 bytes

 

 And the kernel boot log is shown below :

AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
flags: ncq stag pm led clo only pmp pio slum part
No port device detected!
** Bad device size - sata 0 **
SATA device 1: unknown device
** Bad device sata 1 **
MMC: no card present
MMC: no card present
** Bad device mmc 0 **
switch to partitions #0, OK
mmc1 is current device
4437 bytes read in 39 ms (110.4 KiB/s)
## Executing script at 10008000
74 bytes read in 230 ms (0 Bytes/s)
43588 bytes read in 107 ms (397.5 KiB/s)
only CEA modes allowed on HDMI port
----------- trying to load /initrd.img
2318305 bytes read in 1416 ms (1.6 MiB/s)
5119232 bytes read in 1063 ms (4.6 MiB/s)
Kernel image @ 0x10800000 [ 0x000000 - 0x4e1d00 ]
## Flattened Device Tree blob at 13000000
Booting using the fdt blob at 0x13000000
reserving fdt memory region: addr=13000000 size=b000
Using Device Tree in place at 13000000, end 1300dfff
Starting kernel ...
egalax_ts 2-0004: Failed to read firmware version
ft5x06-ts 2-0038: Could not detect touch screen -19.
ili210x_i2c 2-0041: i2c transfer failed
ili210x_i2c 2-0041: Failed to get firmware version, err: -5
imx6q-pinctrl 20e0000.iomuxc: pin MX6Q_PAD_DI0_PIN4 already requested by lcd.21; cannot claim for 2-0048
imx6q-pinctrl 20e0000.iomuxc: pin-91 (2-0048) status -22
imx6q-pinctrl 20e0000.iomuxc: could not request pin 91 (MX6Q_PAD_DI0_PIN4) from group i2c3-tsc2004grp on device 20e0000.iomuxc
tsc2004 2-0048: Error applying setting, reverse things back
tsc2004_reset: write_cmd -5
tsc2004 2-0048: Failed to reset TSC -5
snvs_rtc 20cc034.snvs-rtc-lp: can't get snvs-rtc clock
imx6q-pcie 1ffc000.pcie: phy link never came up
imx6q-pcie 1ffc000.pcie: Failed to bring link up!
imx6q-pcie 1ffc000.pcie: failed to initialize host
adv7180 2-0020: adv7180_read:read reg error: reg=11 ret=-5
mxc_v4l_open: Mxc Camera no sensor ipu0/csi0
mxc_v4l_open: Mxc Camera no sensor ipu1/csi1
mxc_v4l_open: Mxc Camera no sensor ipu1/csi0
mxc_v4l_open: Mxc Camera no sensor ipu0/csi0
update_device_addr: ov5642 ret=-5
ov5642_read_reg:write reg error:reg=300a
update_device_addr: ov5640_mipi ret=-5
ov5640_read_reg(mipi):reg=300a ret=-5
* Setting sysfs variables... * unknown attribute class/rfkill/rfkill0/state
* unknown attribute class/rfkill/rfkill0/type
* unknown attribute class/rfkill/rfkill0/state
* unknown attribute class/rfkill/rfkill0/type
[ OK ]
* Attaching UART to Bluez stack [ OK ]
saned disabled; edit /etc/default/saned
Ubuntu 14.04.5 LTS tengri ttymxc1
tengri login:

 

I have checked the 6x_bootscript file for a possible mistake, but the image having the original 6x script worked fine. The script has been attached herewith. WHat might cause this issue ?

Original Attachment has been moved to: 6x_bootscript.txt.zip

Outcomes