AnsweredAssumed Answered

no communications with TRK-USB-MPC5604B OSBDM

Question asked by duanemattern on Oct 2, 2016
Latest reply on Oct 8, 2016 by duanemattern

Let me start by saying I had a TRK-MPC5606B setup and working with CodeWarrior for MCU (V10.6), but I took that kit to work.  The TRK-MPC5606B is on backorder, so I purchased the TRK-USB-MPC5604B board to use at home.  After rebuilding my project for the different target (5604B),  I expected to be able to use the same RAppID Bootoloader utility to load the firmware on to this board, but I could not establish communication with this board, (it's a bare board without the tower system).  So I downloaded all of the installation software from

http://www.nxp.com/products/software-and-tools/hardware-development-tools/startertrak-development-boards/mpc5604b-startertrak-usb-development-system:TRK-USB-MPC5604B?fsrch=1&sr=3&pageNum=1 

including CodeWarrior V2.10, but that didn't solve the problem, even after uninstalling and re-insalling all of the USB drivers.  I then downloaded OSBDM from https://www.pemicro.com/OSBDM/    as they have an update that is suppose to work with Window10 which is what I'm using, but I still can't establish communications with the TRK-USB-MPC5604B.

 

The USB device drivers are all registered correctly in the device manager (Jungo/WinDriver, OSBDM Debug & Serial ports).  And I am setting J3 Pins1&2 so that the bootloader is started once I press reset.  And I have verified that J6 & J7 are set for pins 1&2 for TX/RX to USB.  As I stated, this worked for the TRK-MPC5606B board, so I had expected RappID bootloader to work the same way for this board.  I do have the osbdm_pemicro tools installed, including osbdmtester.exe, but I don't see my target in the list of options (CF, CFV1, S12, S08, RS08, DSC), and the documentation provided for this utility is sparse.  I tried writing to flash, but just get 0000 when I check that location.

 

So my questions are:

  a) is there anything else I can try to try to get this board to work via USB/serial/BDM?

  b) is there a way I can take the PC out of the loop to see if the problem is the Windows driver or the target

  c) should the original installation (and the RAppID Bootloader Utility)  for the TRK-MPC5606B have worked for this TRK-USB-MPC5604B or is that optimistic.

 

I'm guessing that either I damaged the hardware or that  the OSBDM was not installed or corrupted.    I do have access to USB Multilink for Quorivva, which I can use in an attempt to recover the board, but for $25, I don't know if it is work digging into those details, as I've already spent more time then I had wanted.  I had expected the board to be plug-n-play after getting the TRK-MPC5606 up and running.

Outcomes