AnsweredAssumed Answered

Gstreamer on qt4

Question asked by Xiaoqiang Yang on Sep 29, 2016
Latest reply on Sep 29, 2016 by Xiaoqiang Yang

Hello all,

  I built core-image-base and meta-toolchain-qte on Yocto(L4.1.15_1.1.0-ga)and installed phonon and gstreamer. After build the demo 'qmediaplayer' inside qt-4.8.7, I successfully played video on Windows. Then I compiled the project under linux using my Qt lib created by meta-toolchain-qte. The app can run on my target board and can display the ui, but with no video.

some errors I got:

qmediaplayer:311): GStreamer-CRITICAL **: gst_bin_add_many: assertion 'GST_IS_ELEMENT (element_1)' failed

(qmediaplayer:311): GStreamer-CRITICAL **: gst_element_get_pad: assertion 'GST_IS_ELEMENT (element)' failed

(qmediaplayer:311): GStreamer-CRITICAL **: gst_ghost_pad_new: assertion 'GST_IS_PAD (target)' failed

(qmediaplayer:311): GStreamer-CRITICAL **: gst_element_add_pad: assertion 'GST_IS_PAD (pad)' failed

(qmediaplayer:311): GStreamer-CRITICAL **: gst_object_unref: assertion 'object != NULL' failed

(qmediaplayer:311): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(qmediaplayer:311): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

Gstreamer plugin I install are:gst-meta-base,gst-plugins-bad,gst-plugins-base,gst-plugins-good,gst-plugins-ugly, the version is 0.10, CPU is a single A5 core with out GPU enabled. The app displays on framebuffer.

Some tells my that maybe a gstreamer plugin is missed but I don't know which one.

Who can help me?

 

Thanks in advance!

 

Xiaoqiang

Outcomes