AnsweredAssumed Answered

imx7 hostapd headache

Question asked by Edward Tyrrell on Sep 28, 2016
Latest reply on Oct 5, 2016 by Edward Tyrrell

Hi,

I'm using an imx7sabresd with Yocto 4.1.15 ( Jethro ) with the hostapd package version 2.4 and despite many hours it's still not showing up as an access-point. I've followed many set-ups but still no AP, the AP "looks" like its trying to work.

A few strange things: 1 - all the documentation and web forums speak of /etc/hostapd/hostapd.conf and etc/default/hostapd  my Yocto build has neither directory only /etc/hostapd.conf.

 

I have confirmed and tested wlan0 and can do an 'iw' scan for other APs etc, When hostapd runs I get the following output:

 

root@imx7dsabresd:~# hostapd /etc/hostapd.conf
Configuration file: /etc/hostapd.conf
rfkill: Cannot open RFKILL contro

Dongle Host Driver, version 1.141.88 (r)
Compiled from
l device
wl_android_wifi_on in
mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
mmc1: queuing unknown CIS tuple 0x80 (6 bytes)
F1 signature OK, socitype:0x1 chip:0x4339 rev:0x1 pkg:0x0
DHD: dongle ram size is set to 786432(orig 786432) at 0x180000
dhdsdio_write_vars: Download, Upload and compare of NVRAM succeeded.
dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)
wifi_platform_get_mac_addr
Firmware up: op_mode=0x0005, MAC=00:ae:fa:c7:82:19
Firmware version = wl0: Feb 17 2016 12:06:31 version 6.37.39.36 (r614533)
dhd_wlfc_init(): successfully enabled bdcv2 tlv signaling, 79
dhd_wlfc_init(): wlfc_mode=0x0, ret=-23
wl_create_event_handler(): thread:wl_event_handler:1cc started
CFG80211-ERROR) wl_event_handler : tsk Enter, tsk = 0xa860143c
CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
Using interface wlan0 with hwaddrCFG80211-ERROR) check_dev_role_integrity : 00:ae:fa:c7:82:19 and ssid "GOMOJO"

device role select failed
wlan0: interface state UNINITIALIZED->ENABLED
wlan0: AP-ENABLED

 

The only this that looks possibly wrong is: device role select failed. According to forums I do the following:

"...find the line #DAEMON_CONF="" and replace it with DAEMON_CONF="/etc/hostapd/hostapd.conf"

Again no such directory on my imx7 ( only /etc/hostapd.conf )

Some help on this would greatly be appreciated!!

BR,

Ed.

Outcomes