AnsweredAssumed Answered

Im having issues debugging and measuring the MCU current consumption

Question asked by Fernando Trujillo on Sep 27, 2016
Latest reply on Oct 7, 2016 by Fernando Trujillo

I am currently using the KDS version 3.2.0, and I am having issues when trying to debug my code: sometimes when I run the debug environment it goes straight into running when it should start at a stop to be able to go through every line from the get go if I wish so; the functions "jump into" or "jump over" and overall those tools utilized to go step by step in your code, I can't really use them, when I try them it goes straight into running mode or it just ignores it, its only worked a few times but overall its really inconsistent and can't debug any code.

I am not sure if it has something to do with my environment, I downloaded KDS from the NXP page, installed it, and verified if their were any available updates, and that's it. Is there anything I missed doing to properly install all the environment?

 

On the other hand, I am utilizing a FRDM-KL05Z, and I am trying low power modes and I would like to measure its current, taking advantage of J4 and removing R27. Doing this, if there is no header connecting J4 there should be no voltage on P3V3_MCU, but there is, and the MCU gets powered, and I've been looking though the schematic and I can't really find where this power comes from, so I can't really measure the MCU's current, and overall its really disturbing and it should be an error that P3V3_MCU has a voltage even when J4 is nor connected and R27 has been removed, if not, whats the point for this header.

 

Anyway, thank you. Hopefully someone can help me out on either problem.

Outcomes