AnsweredAssumed Answered

Is my new LPC-Link2 dead?

Question asked by douglaspearless on Sep 23, 2016
Latest reply on Sep 23, 2016 by douglaspearless

I have just received my LPC-LINK2 debugger and I cannot get it to work.

 

I download LPCXpresso for OSX and Linux and tried on three different machines and it will not find my LPC-Link2

 

I also tried:

 

./LPCScrypt_CLI 

LPCScrypt - Commandline Environment v1.8.0 Jul 2016.
Connect target via USB then press Space.
Booting LPCScrypt
No bootable LPCScrypt target found
dfu-util 0.9
Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Deducing device DFU version from functional descriptor length
Found Runtime: [05ac:828d] ver=0118, devnum=7, cfg=1, intf=3, path="20-6.3", alt=0, name="UNKNOWN", serial="UNKNOWN"
(Grepping for 1fc9:000c)
Boot Failed!
Ensure a single LPC18xx or LPC43xx MCU is connected and configured to boot from USB.

 

 

and I also tried:

 

./boot_link2

Looking for DFU devices...

No bootable LPC-Link2 found

 

I have no JP1 or JP2 jumpers in place (per the instructions), I have literally unpacked the device and tried to get it working and after 4 hours of reading manual, searching the forums and the Internet in general, I am rather frustrated.

 

HELP!

 

Cheers

Douglas

Outcomes