AnsweredAssumed Answered

SPI support at u-boot for imx6ul

Question asked by Tanya Groysberg on Sep 19, 2016
Latest reply on Sep 21, 2016 by igorpadykov

Hi,

I'm trying to enable SPI display at the u-boot stage but enabling spi commands at u-boot cause the following errors:
  
common/built-in.o: In function `jumptable_init':
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_init'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_setup_slave'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_free_slave'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_claim_bus'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_release_bus'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/i
nclude/_exports.h:77: undefined reference to `spi_xfer'
common/built-in.o: In function `do_spi_xfer':
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/c
ommon/cmd_spi.c:59: undefined reference to `spi_setup_slave'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/c
ommon/cmd_spi.c:66: undefined reference to `spi_claim_bus'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/c
ommon/cmd_spi.c:69: undefined reference to `spi_xfer'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/c
ommon/cmd_spi.c:86: undefined reference to `spi_release_bus'
/home/tanya/workspace/takti/bitbucket/smartview/BSP/uboot/uboot_2015.10_r0/c
ommon/cmd_spi.c:88: undefined reference to `spi_free_slave'  

 

Thank you in advance,

Tanya

Outcomes