Antonio Orzelli

LPC1200 problem flashing more than 70 kByte

Discussion created by Antonio Orzelli on Sep 12, 2016
Latest reply on Sep 16, 2016 by Antonio Orzelli

Hello,

 

I'm using LPCXpresso v8.1.4, with the LPC1200 REV B demo board.

 

When I flash the micro with a code less than around 70 kByte size, everything works fine; instead, when I try to flash it with a larger code, I got an Erase Sector timeout Error. The targeted micro has 128 kByte of Flash, so it should be possible to download the code in it.

I've already tried 2 demo boards, having the same error.

 

Here there is the log I receive:

 

LPCXpresso RedlinkMulti Driver v8.1 (Mar 11 2016 13:34:34 - crt_emu_cm_redlink build 672)
============= SCRIPT: LPC12XXConnect.scp =============
LPC12XX Connect Script
No probes found
DpID = 0BB11477
AP_ID = 0x04770021
============= END SCRIPT =============================
Probe Firmware: LPC-Link Probe v1.3 (NXP - LPC-Link)
Serial Number: WIN64HS12
VID:PID: 1FC9:0009
USB Path:
Emu(0): Connected&Reset. DpID: 0BB11477. CpuID: 410CC200. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
inspected v.2 On-chip Flash Memory C:\nxp\LPCXpresso_8.1.4_606\lpcxpresso\bin\Flash\LPC11_12_13_128K_8K.cfx
image 'LPC11_12_13 (128K Flash, min 8K RAM) Feb 16 2016 09:19:07'
NXP: LPC1227/301 Part ID: 0x00000000
Connected: was_reset=true. was_stopped=true
LPCXpresso Free License - Download limit is 256K
Writing 73736 bytes to address 0x00000000 in Flash
driver "EraseSector" timeout (3000 ms) PC: 1FFF1536
Target error from Commit Flash write: Ec: Flash driver "EraseSector" timeout (3000 ms) PC: 1FFF1536
(crt_emu_cm_redlink) terminating on communication loss: Pipe has been closed by GDB.

 

Can you help me on this?

Thank you,

Antonio

Outcomes