AnsweredAssumed Answered

How to enable FlexCAN on MarS Board with i.MX6 Dual

Question asked by simoneladwig on Sep 10, 2016
Latest reply on Sep 12, 2016 by simoneladwig

Hello Community,

 

I'm usually not the kind of person, posting questions on the Internet, but this MarS Board is really driving me crazy.

I'm a total noob in compiling and patching kernels. I just did my first kernel compiling a few days ago.

But I really need to enable the FlexCAN on the MarS Board.

 

I have the following problems with the MarS Board since day one:

- can't plug keyboard in it, it wont't recognize my Logitech wireless Mouse and Keyboard set and I don't have another one, it only recognizes my solo wireless mouse but then I can't type anything, of course

- so i ssh into the board to control it remote

I tried following:

- I tried the mainline stable kernel 4.7.3 and the MarS Board Kernel from here Dropbox - source_SVN2642 (3.0.35) and imx freescale kernels linux-2.6-imx.git - Freescale i.MX Linux Tree  in different versions. But everytime I install them on the board, the shell says ok and I reboot, but it stucks in black screen and I have to press the reboot button or cut the power. When I after unplugging use uname -a i have the same kernel as ever.

- I only need to enable CAN, so I tried recompiled the existing kernel from here Dropbox - source_SVN2642 with the menuconfig options for FlexCAN, but of course the same as above

I don't know anything about:

- yocto or builtroot or ....

- i hate the linaro ubuntu on it, but I don't know how to build my own OS for it, I would prefer something smaller, no need for gui

 

So, I'm sorry for the extraordinary long post. But I'm a girl in need.

I would appreciate any help.

I actually don't know what to do anymore...what am I missing???

Bye, Simone

Outcomes