AnsweredAssumed Answered

i.MX 6QP SD Card Boot Problem

Question asked by Janet Estabridis on Sep 6, 2016
Latest reply on Oct 14, 2016 by Janet Estabridis

I am new to the NXP community and so I previously posted in the general community page. I am reposting here.

I have the SABRE board for smart devices  6QP.  I need to have the SDcard have the "core-image-base."

I used the Freescale Yocto Project User's Guide, Rev. L_3.14.38_6ul-ga, 09/2015 and successfully build the image and got all the files in ..MYNAME/tmp/deploy/images/imx6qsabresd.

I imaged the SD card as in Section 6.1:

THE DISK UTILITY SHOWS:   (Partition 2 has /bin /home, etc.)

 

But when I boot I get the following messages:

*****************************************************************************

 

U-Boot 2015.04-imx_v2015.04_3.14.38_6ul_ga+g5d63276 (Sep 05 2016 - 13:43:40)

 

CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
CPU:   Temperature 26 C
Reset cause: POR
Board: MX6-SabreSD
I2C:   ready
DRAM:  1 GiB
PMIC:  PFUZE100 ID=0x10
MMC:   FSL_SDHC: 0, FSL_SDHC: 1, FSL_SDHC: 2
*** Warning - bad CRC, using default environment

 

No panel detected: default to Hannstar-XGA
Display: Hannstar-XGA (1024x768)
In:    serial
Out:   serial
Err:   serial
switch to partitions #0, OK
mmc1 is current device
Net:   FEC [PRIME]
Normal Boot
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc1 is current device
reading boot.scr
** Unable to read file boot.scr **
reading zImage
Error reading cluster
** Unable to read file zImage **
Booting from net ...
FEC Waiting for PHY auto negotiation to complete. done
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
DHCP client bound to address 192.168.0.110 (3325 ms)
Using FEC device
TFTP from server 0.0.0.0; our IP address is 192.168.0.110; sending through gateway 192.168.0.1
Filename 'zImage'.
Load address: 0x12000000
Loading: *
TFTP error: 'No such file or directory' (2)
Not retrying...
BOOTP broadcast 1
BOOTP broadcast 2
DHCP client bound to address 192.168.0.110 (628 ms)
Using FEC device
TFTP from server 0.0.0.0; our IP address is 192.168.0.110; sending through gateway 192.168.0.1
Filename 'imx6q-sabresd.dtb'.
Load address: 0x18000000
Loading: *
TFTP error: 'No such file or directory' (2)
Not retrying...
Bad Linux ARM zImage magic!
=>

*****************************************************************************

Can anyone help me out? 

THANKS IN ADVANCE

Outcomes