AnsweredAssumed Answered

Stop KDS optimising out NOP / NOPs

Question asked by Ben Griffiths on Sep 6, 2016
Latest reply on Sep 12, 2016 by Ben Griffiths

This is another newbie question (I've previously used IAR).

 

For debuggin purposes in a bit of test code I want some nops to single step through

 

If In insert multiple nops e.g.

  __NOP();
  __NOP();
  __NOP();

they seem to be optimised out. How can I stop this.

 

I've selected the following settings but they don't appear to have any effect on keeping the NOPs

Project/Properties/C/C++ Build/Tool Settings/Optimization/Optimization Level = None (-O0)

Project/Properties/C/C++ Build/Tool Settings/Debugging/Debug Level = Maximum (-g3)

Outcomes