AnsweredAssumed Answered

getting Instruction error when build JN5168 zigbee endpoint application

Question asked by Ravi Kumar V on Aug 29, 2016
Latest reply on Oct 13, 2016 by Castaneda Lopez

Dear Sir,

 

I am facing a typical problem while working on JN5168 module.

I a using NXP base device examples for testing ZIGBEE, i have build applications one as coordinator and other as Endpoint.
First i have loaded the coordinator.bin file into JN5168 module and able to see the network formation success using channel 11.

Next i have done factory reset to the board and loaded Endpoint application, but system is crashing at ZPS_eAplAfInit() call.

I am able to see the below message

***********************************************
* END DEVICE RESET *
***********************************************
APP: Entering APP_vInitResources()
APP: Entering APP_vSetUpHardware()
APP: Entering APP_vInitialise()
APP: Entering APP_ZCL_vInitialise()
APP: Entering ZPS_eAplAfInit()

!!! Instruction error
u32PICMR = 0 : u32PICSR = 8008
u32PICMSR = 0 : u32IPMR = 0
u32IHPR = c : u32AINT = 8008 u32PINT 0
EPCR = 0 : EEAR = 0
Stack dump:
4007d18 : 040012c8
4007d1c : 00000000
4007d20 : 00000000
4007d24 : 00000000
4007d28 : 0000000c
4007d2c : 00000000
4007d30 : 00008008
4007d34 : 00000000
4007d38 : 00000000
4007d3c : 00008008
4007d40 : 00000003
4007d44 : 0009b233
4007d48 : 04001fec
4007d4c : 00082519
4007d50 : 040005fc
4007d54 : ffffffff
4007d58 : ffffffff
4007d5c : ffffffff
4007d60 : ffffffff
4007d64 : ffff1504
4007d68 : 00000000
4007d6c : 00000002
4007d70 : 00000002
4007d74 : 00000000
4007d78 : 01ffffff
4007d7c : 010000c8
4007d80 : 01ffffff
4007d84 : 00000000
4007d88 : 00000000
4007d8c : 00000000
4007d90 : 00000000
4007d94 : 0000000d
4007d98 : 00000014
4007d9c : 00080218
4007da0 : 00000000
4007da4 : 00000000
4007da8 : 00000007
4007dac : 00000000
4007db0 : 00000000
4007db4 : 00000000
4007db8 : 00000000
4007dbc : ff00ffff
4007dc0 : f1060134
4007dc4 : 66000003

Outcomes