AnsweredAssumed Answered

Chromium is not running on Wayland

Question asked by Senthil Kumar on Aug 17, 2016
Latest reply on Apr 25, 2018 by Chad Wagner

Hello All,

 

We are tying to run chromium on Wayland Weston compositor.

I am using YOCTO linux distribution in i.MX6Q Sabre SD board.

Chromium version = 48.0.25

Kernel version = 4.1.28-fslc+g0844f

Weston Version = 1.9.0

EGL version = 1.4

 

 

Used following command to run on Weston terminal.

> google-chrome

Getting following error

 

[534:534:0725/083535:ERROR:desktop_window_tree_host_ozone.cc(572)] Not implemented reached in virtual void view

s::DesktopWindowTreeHostOzone::SetWindowIcons(const gfx::ImageSkia&, const gfx::ImageSkia&)

[534:534:0725/083535:ERROR:ozone_webui.cc(60)] Not implemented reached in virtual void views::OzoneWebUI::GetDe

faultFontDescription(std::__cxx11::string*, int*, int*, gfx::FontRenderParams*) const

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

[562:562:0725/083535:ERROR:sandbox_linux.cc(338)] InitializeSandbox() called with multiple threads in process g

pu-process

[534:534:0725/083535:ERROR:ozone_webui.cc(51)] Not implemented reached in virtual gfx::FontRenderParams views::

OzoneWebUI::GetDefaultFontRenderParams() const

/usr/bin/google-chrome: line 11:   534 Segmentation fault      /usr/bin/chromium/chrome ${CHROME_EXTRA_ARGS} $@

 

Please help me to resolve this issue.

 

Thanks,

Senthil.

Outcomes