AnsweredAssumed Answered

CodeWarrior 10.6 with MQX 4.0 debugger issue

Question asked by vines on Aug 4, 2016
Latest reply on Aug 18, 2016 by ZhangJennie

Hi,

 

I recently upgraded my CW software from 10.2 to 10.6. However when I try to debug my application with BSP of MQX 4.0, there was this problem "GDI Protocol fatal error" "The Debugger is not connected to PE device". I am suing PE micro Multilink Universal as my programmer/debugger. I search the forums and I saw a suggestion of updating the driver and then closing CW and re launch with new project workspace. I tried this method but to no avail. I then tried to install MQX 4.2 and debug one of the example programs. I can debug without any problems.

 

You might asked then just used 4.2 instead? My target platform is Kinetis TWR60d100. And I am still using CW compiler. I have not switch to GNU C Compiler yet. On MQX 4.2 there is no BSP for my target platform. And I am hesitant to convert my application to GNU C as it will cause a ton of problems ( align, etc).

 

Is there anything I need to do to be able to debug under CW 10.6/MQX 4.0? Or is this a limitation like I read on 1 of the questions here in forum about no support for MQX 3.8 in CW 10.6.

FYI

I can see that the chip was programmed correctly, but when I try to break then this dialog box pops out.

 

Thanks in advance for the help.

Outcomes