AnsweredAssumed Answered

Problems compiling my linux kernel with bitbake

Question asked by Andreas Schmelter on Aug 1, 2016
Latest reply on Aug 8, 2016 by Andreas Schmelter

Hi,

 

I have a problem when I try to build my own kernel images for the twr-LS1021. I tried it with the virtual box and by installing the sdk on a native system (Ubuntu 14.04 32 Bit). I tried to setup my development system by downloading the sdk images (v1.7 and v2.0) and also by installing it as shown in the following link.

 

4. Create SDK — TWR-LS1021A A documentation

 

When I try to build my kernel, with hob or from the command line, I get the following error. In the command line I tried the commands "bitbake fsl-image-core" and "bitbake virtual/kernel". It is always the same error.

 

(The following messages are written in my log file, which is created automatically)

 

Head of the log file:

----------------------------------------------------------------------------

NOTE: Resolving any missing task queue dependencies

 

Build Configuration:

BB_VERSION        = "1.22.0"

BUILD_SYS         = "i686-linux"

NATIVELSBSTRING   = "Ubuntu-14.04"

TARGET_SYS        = "arm-fsl-linux-gnueabi"

MACHINE           = "ls1021atwr"

DISTRO            = "fsl-networking"

DISTRO_VERSION    = "QorIQ-SDK-V1.8"

TUNE_FEATURES     = "armv7a vfp neon callconvention-hard cortexa7"

TARGET_FPU        = "vfp-neon"

meta             

meta-yocto       

meta-yocto-bsp    = "(nobranch):18837ea4cdd4fdab608e0a032a11a2dfb6b1ee1a"

meta-fsl-arm      = "(nobranch):b529ac5ba06a0d69d7e6e295776a4d684c6e1c56"

meta-fsl-networking = "(nobranch):6eb28ed659bbadfa470237dfce98bcbf53c18fe1"

meta-fsl-toolchain = "(nobranch):a253b3594d8d9e0a4ed869d1fb502c395c4438ac"

meta-virtualization = "(nobranch):df44ec7a68c8e4b713a458a5b93e903103dea85c"

meta-oe          

meta-networking  

meta-perl        

toolchain-layer   = "(nobranch):4a44c4107899363b22c01eb5621b0c86db1c659c"

meta-java         = "(nobranch):65c89b93fa9d4c89e1dfb5b795075cbadb541009"

meta-linaro-toolchain = "(nobranch):9e742fbb8cbb6d2087fb41429a77fcf0ce50dbb8"

meta-security     = "(nobranch):9f4c3849521465b459845dcc1a7a885bacaae9d9"

----------------------------------- Error message (section of the log) -----------------------------------------

WARNING: Failed to fetch URL git://git.freescale.com/ppc/sdk/asf.git;branch=master, attempting MIRRORS if available

ERROR: Fetcher failure: Unable to find revision 62ba10ab6bab8f8f53934e4bb55b5a552bf3fd6b in branch master even from upstream

ERROR: Function failed: Fetcher failure for URL: 'git://git.freescale.com/ppc/sdk/asf.git;branch=master'. Unable to fetch URL from any source.

NOTE: recipe asf-git-r0: task do_fetch: Failed

ERROR: Task 1589 (/home/architech/architech_sdk/architech/ls1021atwr/yocto/meta-fsl-arm/recipes-kernel/asf/asf_git.bb, do_fetch) failed with exit code '1'

NOTE: Running task 2049 of 3909 (ID: 981, /home/architech/architech_sdk/architech/ls1021atwr/yocto/poky/meta/recipes-extended/sysklogd/sysklogd_1.5.bb, do_configure)

NOTE: recipe sysklogd-1.5-r7: task do_configure: Succeeded

NOTE: recipe pkgconfig-0.28-r0: task do_configure: Succeeded

NOTE: recipe openssh-6.5p1-r0: task do_configure: Succeeded

NOTE: recipe linux-ls1-3.12-r0: task do_fetch: Succeeded

NOTE: Tasks Summary: Attempted 2049 tasks of which 15 didn't need to be rerun and 1 failed.

 

The failure happens independent from the environment where my system is running. In one environment I hav to use a proxy, the other network works without a proxy.

 

Can anyone explain me what the reason for this problem is?

 

Thanks for your help and kind regards,

 

Andreas Schmelter

Outcomes