AnsweredAssumed Answered

problem about update Qt version to 5.6 with yocto

Question asked by chen yw on Jul 31, 2016
Latest reply on Aug 2, 2016 by chen yw

I want cross compile qt5.6 for imx6sx,but the lastest Qt version of yocto(i use imx-4.1.15-1.0.0_ga) is 5.5.1,

so i replace source/meta-qt5 with new meta-qt5 directory git clone from https://github.com/meta-qt5/meta-qt5.git and the branch is krogoth,then,bitbake fsl-image-qt5 without any problem except these warnings:

WARNING: QA Issue: gdb: invalid PACKAGECONFIG: readline [invalid-packageconfig]

WARNING: lttng-modules: no modules were created; this may be due to CONFIG_TRACEPOINTS not being enabled in your kernel.

WARNING: QA Issue: devil rdepends on tiff, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: devil rdepends on liblzma, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: The /usr/share/info/dir file is not meant to be shipped in a particular package. [infodir]

WARNING: QA Issue: qtbase-plugins rdepends on freetype, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: qtbase-plugins rdepends on fontconfig, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: qtbase rdepends on freetype, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: qtbase rdepends on libicui18n, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: qtbase rdepends on fontconfig, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: qtbase rdepends on libicuuc, but it isn't a build dependency? [build-deps]

WARNING: QA Issue: imx-gpu-viv: /imx-gpu-viv-tools/usr/bin/gmem_info is owned by uid 1000, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]

WARNING: QA Issue: imx-gpu-viv: /imx-gpu-viv-tools-apitrace/usr/lib/apitrace/wrappers/egltrace.so is owned by uid 1000, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated]

 

 

but when i burn u-boot,zImage and rootfs to imx6 and run the qt demo(qt5everywheredemo-1.0), Segmentation fault is display like this:

file:///usr/share/qt5everywheredemo-1.0/qml/QtDemo/main.qml:124:5: QML FontLoader: Cannot load font: "file:///usr/share/qt5everywheredemo-1.0/qml/QtDemo/fonts/PatrickHandSC-Regular.ttf"
Segmentation fault.

 

so i make a test,  test.qml    like this:

Rectangle{

     color:"green";

}

it can run well; but when i add a line to Rectangle like this

Rectangle{

     color:"green"

     Text{text:"this is a test"}

}

I got a Segmentation fault again.

 

please tell me what should i do , thank you.

 

I have tried append freetype fontconfig uic these things to RDEPENDS and DEPENDS in source/meta-qt5/recipes-qt/qt5/qtbase_git.bb,but nothing changed.

Outcomes