AnsweredAssumed Answered

1 Mb/s CAN ?

Question asked by Mahtab Sarwar on Jul 19, 2016
Latest reply on Jul 21, 2016 by Mahtab Sarwar

Hi,

 

I have the S12ZVC Evaluation board. I'm trying to get CAN working at 1 Mbit/ s baud rate; 500 kbit/s works fine, transmitting and receiving. I can even get 800 kbit/s; but I can't get 1000 kbit/s (1Mb/s).

 

I've tried using both Processor Expert and coding by hand - I can get the lower baud rates working by both methods. Processor expert sometimes says the baud rate is not achievable when you first start a project but if you save, exit and retry it lets you select 1Mb/s using high speed mode and the external clock.

 

When I run the project at 1000kbit/ s it doesn't send or receive; it's like CAN is off or the bus is off. I'm assuming it's because that baud rate is unachievable with this board but it should be.

 

There aren't many details that came with the board, like whether there is an external oscillator and what the clock rate is and I don't know which settings to use in processor expert: internal clock or external. Any help in configuring the clock and the registers would be appreciated..I'm attaching screen shots of my processor expert settings below.

 

Also, I'd prefer to do it by hand rather than processor expert: at least by hand, you get bus errors but it still transmits. With processor expert the tx is just dead.

 

Max

Outcomes