AnsweredAssumed Answered

FRDM-K82F , bootloader device does not appear in win 7

Question asked by Javier Soriano on Jul 19, 2016
Latest reply on Jul 20, 2016 by jeremyzhou

Dear All,

 

I bought a couple of these boards. One of them worked correctly  after switching to firmware "JLink_OpenSDA_V2_1_2015-10-13.bin" . I can see the device in the device manager, and can program it via Kinetis Design Studio.

 

I tried to setup the second board, by starting it as bootloader (RESET button). I was able to see the BOOTLOADER drive, and then I flashed the above-mentioned firmware. However, this time I briefly saw a message stating that the file was too big (or the space was too small?). The device disappears, and I cannot get it to show up again. No BOOTLOADER, no OPENSDA device either.

 

Ideas from the back of my memory:

a)  While trying to get the first board up and running, I recall having tried to flash a different firmware, as in some site I read that openSDA2.1 would not fit in the memory allocated by the original P&E firmware. Which one did I flash? I do not remember, but it could be one of the following, based on the files that I still have on my disk:

- 04_OpenSDA_FRDM-K82F.bin

- JLink_OpenSDA_V2_1.bin

- OpenSDA_V2_1.bin

 

Is there a specific order in which the firmware needs to be updated? The board was originally showing as an MBED device.

 

b) I can program the K82 using J11 and the flashing tool. This seems to be no problem. However, I would like to get the K20 up and running again. I saw in another post that there is a bin file for the K20 that is mounted on the same board. The quesiton is, how to get it in there?

 

Is there a way to program the K20 without having access to a JTAG debugger? E.g. by programming via the K82, or something else?

 

 

Thanks in advance for the help. I hope my that my board is done for

 

Javier

Outcomes