AnsweredAssumed Answered

Can't debug an application in KDS with Segger j-link

Question asked by Jenia Brook on Jul 19, 2016
Latest reply on Jul 20, 2016 by Jorge Antonio Alcala Vazquez

Hello,

I've a problem to debug the code on KE04Z128 (Not on evaluation board). It just seems to be stuck, not even stops at the beginning of main() function.

 

It used to work good, I have some LED Blink program that worked good, until I started to implement Serial Bootloader (accordingly to AN4767 document) on that micro-controller.

 

First of all the Serial Bootloader was implemented on FRDM-KE06Z evaluation board and it worked great, I've been able to upload a S19 (srec) file through the AN2295 PC to the FRDM-KE06Z and verified that it worked as it should be.

 

After that I've started to implement the bootloader on KE04Z128. The communications through UART (RS485) between the AN2295 PC and the target is good, I can erase addresses (from 0x4000 to end of flash --> 0x4000 is where my app should start) but not be able to program (another story...).

 

So I decided go back to the LED Blink program, and now as I said before, I can't debug it.

I've opened a new project and write another LED Blink program, still no result, it stuck.

When I go back to bootloader project I can debug it. Other projects I can't debug.

 

I don't know what seems to be a problem and from where to begin to solve this annoying issue.

Is anyone could guide me through?

 

Thank you.

Jenia

Outcomes