AnsweredAssumed Answered

Problem with downloading FSL Yocto BSP

Question asked by Xi Fan on Jul 18, 2016
Latest reply on Jul 19, 2016 by Xi Fan

Hi,

I am newbie in this field and have now problem with downloading FSL Yocto BSP in virtual machine Ubuntu Linux V14.04. the host system is Win7. I followed the guide: Freescale_Yocto_Project_User's_Guide.pdf.

 

- I am behind proxy server, but with the correct proxy settings, I can download and install the host packets successfully.

  (section 3.1 of the user's guide)

 

-  Following the section 3.2 I can setup the repo utility without any problem

 

After that I want to setup Yocto Project (section 4)

- I registered the git with the username and password

- generated the folder fsl-release-bsp

- At running the command repo init -u git://git.freescale.com/imx/fsl-arm-yocto-bsp.git -b imx-4.1.15-1.0.0_ga

  I get the following error messages:

 

/home/xfamed/bin/repo: line 1: html: No such file or directory

/home/xfamed/bin/repo: line 2: head: No such file or directory

/home/xfamed/bin/repo: line 3: title: No such file or directory

/home/xfamed/bin/repo: line 4: meta: No such file or directory

/home/xfamed/bin/repo: line 5: META: No such file or directory

/home/xfamed/bin/repo: line 6: meta: No such file or directory

/home/xfamed/bin/repo: line 7: style: No such file or directory

/home/xfamed/bin/repo: line 9: border:3px: command not found

/home/xfamed/bin/repo: line 9: $'\r': command not found

/home/xfamed/bin/repo: line 10: background-color:#fff: command not found

/home/xfamed/bin/repo: line 10: $'\r': command not found

/home/xfamed/bin/repo: line 11: margin:1.5em: command not found

/home/xfamed/bin/repo: line 11: $'\r': command not found

/home/xfamed/bin/repo: line 12: padding:1.5em: command not found

/home/xfamed/bin/repo: line 12: $'\r': command not found

/home/xfamed/bin/repo: line 13: font-family:Tahoma,Helvetica,Arial,sans-serif: command not found

/home/xfamed/bin/repo: line 13: $'\r': command not found

/home/xfamed/bin/repo: line 14: font-size:1em: command not found

/home/xfamed/bin/repo: line 14: $'\r': command not found

/home/xfamed/bin/repo: line 15: $'}\r': command not found

/home/xfamed/bin/repo: line 16: h1: command not found

/home/xfamed/bin/repo: line 17: font-size:1.3em: command not found

/home/xfamed/bin/repo: line 17: $'\r': command not found

/home/xfamed/bin/repo: line 18: font-weight:bold: command not found

/home/xfamed/bin/repo: line 18: $'\r': command not found

/home/xfamed/bin/repo: line 19: color:#196390: command not found

/home/xfamed/bin/repo: line 19: $'\r': command not found

/home/xfamed/bin/repo: line 20: $'}\r': command not found

/home/xfamed/bin/repo: line 21: b: command not found

/home/xfamed/bin/repo: line 22: font-weight:normal: command not found

/home/xfamed/bin/repo: line 22: $'\r': command not found

/home/xfamed/bin/repo: line 23: color:#196390: command not found

/home/xfamed/bin/repo: line 23: $'\r': command not found

/home/xfamed/bin/repo: line 24: $'}\r': command not found

/home/xfamed/bin/repo: line 25: /style: No such file or directory

/home/xfamed/bin/repo: line 26: /head: No such file or directory

/home/xfamed/bin/repo: line 27: body: No such file or directory

/home/xfamed/bin/repo: line 28: div: No such file or directory

/home/xfamed/bin/repo: line 29: h1: No such file or directory

/home/xfamed/bin/repo: line 30: p: No such file or directory

/home/xfamed/bin/repo: line 31: syntax error near unexpected token `<'

'home/xfamed/bin/repo: line 31: `<p><b>User:</b> 163.50.61.157 </p>

 

Could someone help me to find out the reason, why the repo init didn't work?

Some settings missing?

Thanks

Xi

Outcomes