AnsweredAssumed Answered

u-boot-fw-utils build failed for SDK2.0 on ls1043ardb

Question asked by Hoa Nguyen on Jul 14, 2016
Latest reply on Aug 1, 2016 by Hoa Nguyen

Hi all,

I am trying to add fw-printenv and fw_setenv to the Linux without much success. Here are my steps:

1) Confirm that the file u-boot-fw-utils_2015.07.bb is in meta/recipes-bsp/u-boot/ folder

2) Confirm that the UBOOT_CONFIG = "ls1043ardb_config" is in meta-freescale/conf/machine/ls1043ardb.conf

3) Add u-boot-fw-utils to IMAGE_INSTALL_append in meta-freescale/recipes-fsl/fsl-image-core.bb

4) Run bitbake fsl-image-core and have the following errors

 

hoa@ubuntu:~/Workspace/QorIQ-SDK-V2.0-20160527-yocto/build_ls1043ardb$ bitbake fsl-image-core
Loading cache: 100% |###########################################| ETA:  00:00:00
Loaded 3421 entries from dependency cache.
NOTE: Resolving any missing task queue dependencies
ERROR: Nothing RPROVIDES 'u-boot-fw-utils' (but /home/hoa/Workspace/QorIQ-SDK-V2.0-20160527-yocto/sources/meta-freescale/recipes-fsl/images/fsl-image-core.bb RDEPENDS on or otherwise requires it)
ERROR: u-boot-fw-utils was skipped: Only config,images can be specified!
NOTE: Runtime target 'u-boot-fw-utils' is unbuildable, removing...
Missing or unbuildable dependency chain was: ['u-boot-fw-utils']
ERROR: Required build target 'fsl-image-core' has no buildable providers.
Missing or unbuildable dependency chain was: ['fsl-image-core', 'u-boot-fw-utils']

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

 

If I add u-boot-fw-utils in the local.conf instead I have similar error. It looks like that u-boot-fw-utils is not built.

Could someone take a look and let me know what I am missing?

 

thanks,
hoa

Outcomes