AnsweredAssumed Answered

P1022 Processor emulator attach failure

Question asked by ramesh marichamy on Jul 13, 2016

Hi

We have designed our processor card based on P1022 processor chipset & NAND flash as the primary boot memory. the prototype was designed in 2014 and we have made 30+ boards.

In our recent lot, we are facing a issue with the P1022 processor booting. we could not attach the emulator (code warrior) to the processor chipset. whenever attached it says "could not reset the target", "elf is not in expected halt mode". the problem is reported in three different modules.

I have verified all the power supplies, power on strappings, boot configurations, clocks etc. But the module behaviour seems un predictable. The problem encountered is as explained.

 

1.After the module is assembled all power on checks completed and all supplies are meeting the targets.

2.Clocks were verified and found ok.

3.Reset section to the processor and power on strappings were set and the module was accessed through emulator.

4.initially emulator did not attach. after trying three four times, the emulator attach happened.

5.Then we initalized the processor and DDR memory read write was verified and found ok.

6.Then we tried loading the Uboot file to the NAND drive and it was loaded successfully. (attached the log for reference).

7.we tried rebooting the processor. at that time the asleep LED of processor is glowing continuously and HRESETREQ# signal is continuously asserted at every 2ms. chip select to NAND flash is continuously asserting.

8.after this we tried to attach the emulator , but it did not attach and was giving "could not reset the target".

9.I have exported the diagnostics log from the code warrior tool and attached for reference.

10.We have also taken a snap of the register dump while the emulator got attached.

11.We tried changing the boot mode to SPI boot rom and tried to attach emulator. still in vain.

12.In two other modules where similar problem is reported, the emulator got randomly attached through SPI mode. the register dump as of those modules were also attached and the register values are varying.

Is there any errata or any change in the silicon version as we don not encounter the problem in other serial modules assembled earlier.

Regards,

Ramesh.M

Original Attachment has been moved to: 201607141858_DiagnosticInfo.zip

Original Attachment has been moved to: P1022-code-warrior-reg-dumps.zip

Outcomes