AnsweredAssumed Answered

Cannot login with non-root username on imx28

Question asked by luheng wang on Jul 11, 2016
Latest reply on Aug 1, 2017 by wu my

May I login imx28 built with yocto with non-root username?

hw-platform: imx28

build system: "https://github.com/Freescale/fsl-community-bsp-platform -b fido"

fs-image: core-image-full-cmdline

kernel: 3.12.6

 

Description: After I created a non-root user with command "useradd", I tried to login with newly created username and failed. I failed both on console and with ssh. The command 'last' shows that the newly id has login successfully but logout immediately. So it's not that the creation of new username has not rightly performed. I manually typed in 'login', and then feed with newly created username and passwd, and a string "Killed" prompted. After tracing the code of 'shadow', I found that the authentication of the non-root has passed and 'shadow' is calling 'execle' to switch to log-in bash. It looks like the log-in bash is killed.

 

I tried with 'core-image-full-cmdline', 'core-image-minimal', I even tried with officially built "http://downloads.yoctoproject.org/releases/yocto/yocto-1.8/machines/imx28evk/core-image-minimal-imx28evk.tar.bz2", but I got the same error.

 

I searched on web but no relevant page was found. It seems that only few people uses non-root user to login embedded system.

 

Is there something I missed? Or, we just cannot login with non-root user with yocto built system?

Outcomes