AnsweredAssumed Answered

CW 8.3 new project link issue

Question asked by Dip kamat on Jul 6, 2016
Latest reply on Jul 11, 2016 by Fiona Kuang

Hi,

I am using CW 8.3 IDE for DSP56F805 MCU.The project was previously compiled and built(almost 7yrs back) using code warrior 4.02 and SDK ver 2.4.I have the source folder(.c,.h and .mcp) along with compiler and linker settings(.xml files) and configflash folder (linker.cmd file).

I tried to open the projectusing 4.02 ide on win XP machine.But the IDE crashed after giving compatibility error.

So i migrated to CW8.3 IDE.This ide doesnt make use of separate SDk as it supports processor expert.

I created a new project and dragged the source files(.c and .h files).I deleted the old .mcp project file. i also replaced the linker.cmd file with the old linker file present in the project configFlash folder. Since the sode is dependent on SDK,i mentioned the sdk file paths in properties->access paths.

when i try to compile the sources it does not give error.

I then tried to build the project by clicking on make button.

This gave me link error in interrupt file vector.c file of SDK. the interrupt.asm files of SDK are not getting linked properly.

Is there any other way to link the .asm file?

please help me in this since i am new to this linker errors.

Outcomes