AnsweredAssumed Answered

The Manufacturing Tool failing to flash

Question asked by Michael Worster on Jun 29, 2016
Latest reply on Jul 6, 2016 by Michael Worster

I'm trying to use the Manufacturing Tool MfgTool2.exe to flash my MCIMX6Q-SDB SABRE board, I've tried both SDCard and eMMC and I'm getting the same results, the tool hangs during the partition step.

 

From the Downloads Page:
SABRE Platform for Smart Devices|NXP

I grabbed the latest version of the Manufacturing Tool:

IMX6_M6.0.1_2.0.0_MFG_TOOL (REV M6.0.1_2.0.0)

 

I've read through the documentation and it appears that the configuration is fairly well setup "out of the box" so I didn't initially make any changes to it.

I set my SABRE board to boot mode (SW6=00000000) and connected the USB OTG to my Windows 7 machine, I was able to see it show up with proper VID/PID (15A2/0054). I also connected the UART-to-serial connection to my PC so I could see the progress as well.

 

After that I launched the MfgTool2.exe with Administrator permissions. I was able to see the steps start until the tool reported "Partitioning..." This seems to be the mksdcard.sh script running on the target device. From my terminal prompt I was able to see “wait for /dev/mmcblk0 appear” printed over and over again.

 

I also tried changing the cfg.ini script to point to the eMMC list instead, but that locks up at the same place.

Any thoughts on what is going wrong here?

Thanks.

-Mike

 

Note: even though they're mostly default, I'm attaching the cfg.ini and ucl2.xml. I'm also attaching the MfgTool.log showing the last command (sh mksdcard.sh) and the mfgtool_stuck.txt which is the serial console log from my SABRE Quad board.

Original Attachment has been moved to: ucl2.xml.zip

Original Attachment has been moved to: cfg.ini.zip

Original Attachment has been moved to: mfgtool_stuck.txt.zip

Original Attachment has been moved to: MfgTool.log.zip

Outcomes