lpcware

LPC Link-2 problem

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by andres.cass on Thu Oct 29 06:25:10 MST 2015
Hi,
Recently I get a LPC Link-2 debugger. But when I try to donwload a firmware to a board (that works fine with a LPOC Link-1 probe) the LPCXpresso IDE launch a number of error messages.

When I first connect the probe to the PC it appears as "LPC" in de Window's devices window. If I try to debug directly from the IDE it throws the following message:
"Error reported by server (redlinkserv.exe): RedlinkAPI: hardware interface transfer error"

And the LPCLink led starts blinking and in the devices window it apperas now as LPCLINK2 Redlink.

If I try again directly it throws:
"Error reported by server (redlinkserv.exe): RedlinkAPI: hardware interface transfer error
Redlink server has been terminated and will be restarted.
Please restart your debug session.
If the problem recurs, please power cycle your debug probe and restart LPCXpresso"

If I power cycle the debug probe, happens the same.

I tried removing the conttrolers, reinstalling the with the lpc_driver_setup.exe but nothing changes.

I've tried to boot the probe from command line and from the IDE but nothing changes

I am using LPCXpresso  v7.5.0 [Build 254] [2014-10-31] on Windows 7 64 bits.

Thank you

Outcomes