lpcware

Can't connect to LPCXpresso board Target LPC1343 with Linux

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by DiBosco on Wed Feb 29 05:52:34 MST 2012
I have found a similar thread discussing similar issues, but it's out of date and my errors are a little different, so thought I'd start a new thread.

When I try to connect to my LPCXpresso LPC1343 board I am just getting a timeout. When I try the recommended:

dfu-util -d 0x0471:0xdf55 -c 0 -t 2048 -R -D LPCXpressoWIN.enc

I get the following message:

Quote:

Opening USB Device 0x0471:0xdf55...
Claiming USB DFU Runtime Interface...
Determining device status: state = dfuDNLOAD-IDLE, status = 0
WARNING: Runtime device already in DFU state ?!?
Found Runtime: [0x0471:0xdf55] devnum=8, cfg=0, intf=0, alt=0, name="UNDEFINED"
Claiming USB DFU Interface...
Setting Alternate Setting ...
Determining device status: state = dfuDNLOAD-IDLE, status = 0
aborting previous incomplete transfer
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
Transfer Size = 0x0800
bytes_per_hash=604
Starting download: [#######################dfu_download error -32
Error during download

However, the IDE gives me this error:

[IMG]http://www.apostrophe.co.uk/linux/timeout.jpeg[/IMG]


lsusb clearly shows the device is there and changing permissions makes no odds.

Would be most grateful for a fix as I'm on a course with NXP right at this moment!

Outcomes