lpcware

Fedora Linux 15 64-bit - troubles with install LPCXpresso 4.0.5

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by LTTechPL on Sat Jul 23 04:51:36 MST 2011
I've installed especially for LPCXpresso Fedora 15 64-bit (I've x85_64 machine, so that version is optimal) and I can't install Tool-chain :
$ ./Installer_LPCXpresso_4.0.5_113_Linux-x86 
$ md5sum Installer_LPCXpresso_4.0.5_113_Linux-x86
b803905f4e7888bbd5c0418f66d0a58a  Installer_LPCXpresso_4.0.5_113_Linux-x86
$
strace version:
$ strace ./Installer_LPCXpresso_4.0.5_113_Linux-x86
execve("./Installer_LPCXpresso_4.0.5_113_Linux-x86", ["./Installer_LPCXpresso_4.0.5_113"...], [/* 88 vars */]) = 0
[ Process PID=9894 runs in 32 bit mode. ]
old_mmap(0xc7d000, 4096, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0xc7d000) = 0xc7d000
readlink("/proc/self/exe", "[...]/Installer_LPCXpresso_4.0.5_113_Linux-x86", 4096) = 111
old_mmap(0x8048000, 1175419, PROT_READ|PROT_WRITE|PROT_EXEC, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x8048000
mprotect(0x8048000, 1175416, PROT_READ|PROT_EXEC) = 0
old_mmap(0x8167000, 39975, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0x11f000) = 0x8167000
mprotect(0x8167000, 39972, PROT_READ|PROT_WRITE) = 0
old_mmap(0x8171000, 716, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x8171000
brk(0x8172000)                          = 0x9ce8000
open("/lib/ld-linux.so.2", O_RDONLY)    = -1 ENOENT (No such file or directory)
_exit(127)                              = ?
$ getenforce
Permissive
Update :
# yum install glibc.i686
$ ./Installer_LPCXpresso_4.0.5_113_Linux-x86
invalid command name "bind"
    while executing
"::unknown bind Text <Tab>"
    ("uplevel" body line 1)
    invoked from within
"uplevel 1 $next $args"
    (procedure "::obj::Unknown" line 3)
    invoked from within
"bind Text <Tab>"
    (procedure "::InstallJammer::InitializeGui" line 19)
    invoked from within
"::InstallJammer::InitializeGui "
    (procedure "::InstallJammer::InitInstall" line 68)
    invoked from within
"::InstallJammer::InitInstall"
    (file "/installkitvfs/main.tcl" line 36433)
OK, that solves problem :
# yum install -y gtk2.i686

Outcomes