lpcware

"No emulators" error

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by il_mix on Mon Aug 06 02:15:46 MST 2012
Hi everyone.
I'm using a custom board with a LPC1788 and a LPC1313 on it. I'm used to program both using LPCLink on LPCXpresso board.
I'm using WindowsXP and LPCXpresso v4.2.0 [Build 264] [24/02/2012].
Everything worked fine since a while ago...

I get a strange error now when trying to program the LPC1313, that seems to be connected more on the IDE than on the hardware.
When I try to program the LPC1313, or erase its memory, I get a "No emulators" error.

I noticed that when trying to erase LPC1788 memory (after setting LPC1788 in "MCU settings"), with the MCU disconnected from the LCPLink, the IDE think about it a little, than give me:
"02: Failed on connect: Ep(01). Target marked as no debuggable.".
With LPCLink connected, the MCU erase/programs correctly.

When I try to erase memory of LPC1313 (after setting LPC1313 in "MCU settings"), again with LPCLink disconnected, I get a "No emulators" error as soon as I start the erase process.
I get the same error with the LPCLink connected.

What's going on?
Thanks for your help!

Outcomes