lpcware

LPC18xx and LPCXpresso with LPC-Link 2

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by hamu on Thu Mar 06 00:59:54 MST 2014
Hello,

Till now I used LPCXpresso v6.0.2_151 with the LPC-Link debugger to flash/debug my LPC18xx target. All worked fine for many month.

Now I bought a LPC-Link 2 debugger and I can´t flash/debug my target!. I Always get the error message

Flash driver "UnInit" return code 0x0
15: Target error from Commit Flash write
System rejected access at location 0x10001A10 - verity Population of memory and peripherals


Here are the Debug messages:
LPCXpresso RedlinkMulti Driver v6.0 (Sep 17 2013 18:02:04 - crt_emu_cm_redlink build 244)
Looked for chip XML file in C:/nxp/LPCXpresso_6.0.2_151/lpcxpresso/bin/LPC1833.xml
Looked for vendor directory XML file in C:/nxp/LPCXpresso_6.0.2_151/lpcxpresso/bin/NXP_directory.xml
Found generic directory XML file in C:/nxp/LPCXpresso_6.0.2_151/lpcxpresso/bin/crt_directory.xml
Emu(0): Conn&Reset. DpID: 2BA01477. CpuID: 410FC230. Info: (null)
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Loaded LPC18x3_43x3_2x256_BootA.cfx: LPC18x3/LPC43x3 Flash 2x256KB @0x1A000000 (Boot Bank A) Jul 22 2013 10:38:30  On-chip Flash Memory
Connected: was_reset=true. was_stopped=false
v LPCXpresso Free License - Download limit is 256K
driver "UnInit" return code: 0x0
Target error from Commit Flash write: Em(12). System rejected access at location 0x10001A10 - verify Population of memory and peripherals
Stopped: Halt

The adress location changes every time...

I have already tried all posibilities mentioned in this forum (enabling vector catch, ....) but nothing works.


If I switch back to the old LPC-Link all works fine again.

Can anybody help me with this issue?

Thanks
Thomas


Outcomes