lpcware

LPC1857 debug error - failed to connect

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Nemanja on Mon Nov 26 10:08:56 MST 2012
Hello,

I'm using Keil MCB 1857, and NXP LPC-Link (cut off from LPCXpresso board) for debugging, and when I try to run some basic program from the LPCXpresso, I get the following error:
02: Failed on connect: Ep(01). Target marked as not debuggable.
Emu(0): Connected. Was: None. DpID:     EDB6. Info: HID64HS12

I checked this link: http://support.code-red-tech.com/CodeRedWiki/MarkedNotDebuggable

Cable is fine, board is powered, debug circuit is default and board is brand new, so no reason why the flash would be locked... Any ideas?

By the way, in Debugger options I choose NXP LPC18xx (SWD), and after I run it with that setup I get an asterisk after that string (*), like something has been changed in the configuration. When I choose the option without an asterisk, next time I run it I get something like this (together with the previously mentioned 02:Failed on connect... error):
Error in final launch sequence
Failed to execute MI command:
-target-select extended-remote | crt_emu_lpc18_43_nxp -g -mi -2 -pLPC1857 -vendor=NXP -wire=hid -msg-port=50800

Thanks in advance,
Nemanja

Outcomes