lpcware

LPCXpresso and J-Link: I can't start a debug session

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by giusloq on Thu Oct 08 10:08:59 MST 2015
Initially I configured a debug session through the generic GDB Hardware Debugging plug-in, as described in this link.
I was able to start a debug session, single stepping, watch variables and registers and similar things. But it was impossible to restart the MCU (LPC1778).

As suggested in the link above, I installed and configured GNU ARM Eclipse plugin, but the debug session can't be started. After the initial step of memory programming (I think the memory is programmed correctly), LPCXpresso shows the following error
Error in final launch sequence
Error executing step execute method: stepStartTrackingBreakpoints
java.lang.reflect.InvocationTargetException


Please, does someone know how to solve this problem?

The very bad thing is that now I can't debug either with GDB Hardware Debugging plug-in, even if it worked before. I receive the same error! Now it's impossible to debug anything  :((  J)

J-Link works well because I can program the memory with its command line tool.

Outcomes