lpcware

NGX LPC-4330-Xplorer UART RX not working

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 18, 2016 by lpcware
Content originally posted in LPCWare by dalzan on Thu May 26 15:35:14 MST 2016
Hi,
I have NGX LPC-4330-Xplorer board;
pins U0_TXD (9), U0_RXD (10) and GND (1) are interconnected to FTDI cable C232HD pins RXD,TXD,GND.
I tried to debug project  "periph_uart_rb"  from package lpcopen_2_12_lpcxpresso_ngx_xplorer_4330.zip
On start it prints initial text:

LPC18xx/43xx UART example using ring buffers
Press a key to echo it back or ESC to quit

but when i press any key there is no echo, no reaction at all.
I think it should repeat the char pressed and LED should toggle.
I measured the FTDI cable and there is 115200 Bd 1Start+8Data+1Stop bit on its TX output pin as expected.

I have the TX and RX pins interconnected through 2k2 resistor to avoid damage,
but later during testing also tried to connect cable_TX to LPC_RX directly, no success.

Also tried project "periph_uart", no reaction to pressed key, only prints some text.

Any idea what could be wrong or what to try ?

Outcomes