lpcware

Failed on connect. Target marked as not debuggable

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 18, 2016 by lpcware
Content originally posted in LPCWare by vivien.wong on Thu Mar 17 23:11:34 MST 2016
Hi,

   I am using a LPC1857 and I am not able to connect to the LPC-Link2 or Red Probe debugger. This is what I've tried out:

1. I am able to enter ISP mode and I erased the entire flash bank A and bank B and then I tried to debug but still to no avail. This rules out that the firmware is problematic since even on a completely erased part, I cannot enter debug mode.
2. CRP is definitely disabled.
3. I enabled "Vector Catch" in debugger option and that didn't work too.

  Since firmware code is likely not the culprit, could anyone give me pointers on what part of the hardware I should be checking to ensure that I can get to debug to work? I read that Vtref between target and debugger hardware have to match. How do I check and ensure this is the case?


Thank you!

Vivien

Outcomes