lpcware

USB IAP Problem - Not Working

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Ulysses on Fri Feb 26 16:26:40 MST 2010
[COLOR=#1F497D]We need to implement USB-based IAP  (per the user manual, this is a built-in capability in this part)  We have tried every possible configuration to no avail. What I would like to see is a confirmed correct minimum schematic (or description thereof) that is guaranteed to work.  So far we have tried this with our custom board and a modified LPCxpresso board.[/COLOR]
  [COLOR=#1F497D] [/COLOR]
  [COLOR=#1F497D]LPCxpresso board:[/COLOR]
  [COLOR=#1F497D]With the debugger section connected and disconnected, with the pIO0.1 pin jumpered to ground with a  10k pulldown, and  PIO0.3 connected to USB cable V+ through a 50k resistor, and a 1.5k pullup on D+ to 3.3v when plugged in, the PC tried to enumerate and fails. [/COLOR]
  [COLOR=#1F497D]The LPCxpresso board seems to boot into user code (flash programmed with the “Blinky” example) with the LED blinking merrily away, so it seems the IAP rom doesn’t get executed. [/COLOR]
  [COLOR=#1F497D]Questions: [/COLOR]
  [COLOR=#1F497D]-[FONT=&quot]        [/FONT][/COLOR][COLOR=#1F497D]Is there any special treatment of the reset line (besides a pullup resistor) that is need ? [/COLOR]
  [COLOR=#1F497D]-[FONT=&quot]        [/FONT][/COLOR][COLOR=#1F497D]What is the timing from reset where the pIO0.1 and 0.3 pins are sampled? [/COLOR]
  [COLOR=#1F497D]-[FONT=&quot]        [/FONT][/COLOR][COLOR=#1F497D]Are there any implications with IAP from having the SWD debug enabled and/or connected to a debug interface ?[/COLOR]
  [COLOR=#1F497D]-[FONT=&quot]        [/FONT][/COLOR][COLOR=#1F497D]Does the IAP USB rom expect to control the USB connect line though a transistor, or will a simple pullup do? [/COLOR]
  [COLOR=#1F497D] [/COLOR]
  [COLOR=#1F497D]On our custom board we control the USB connect line though a transistor per the example in the user manual, but that doesn’t seem to help.  We have never enabled CRP of any kind.  I don’t believe the watchdog is enabled either. On our custom board, we are using CMSIS 1.3 with freeRTOS.  The LPCxpresso board is just running ‘blinky’.[/COLOR]
  [COLOR=#1F497D] [/COLOR]
  [COLOR=#1F497D]Any help would be greatly appreciated.[/COLOR]

Outcomes