lpcware

Issues while program flash multiple device

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by partheepan on Wed Sep 09 06:31:21 MST 2015
Hi,

I am using a couple of lpc824 boards (OM13071).

I have connected them to a single pc and trying to flash program them by selecting the device from the connect to emulator pop up. Whichever device I select the same device is programmed again and again and not the other one by the GUI.

I tried coping the flash command from GUI and got this one

crt_emu_cm_redlink -flash-load-exec "C:\Users\elpk5\Documents\LPCXpresso_7.8.0_426\workspace\i2cTest\Debug\i2cTest.axf" -g -2  -vendor=NXP -pLPC824    -reset=vectreset -flash-driver=LPC800_32.cfx

Where this one is the same for whichever device I select. And this command doesnt specify anywhere that it selects the specific device.

I then moved to the command line and tried to select a particular device but unable to succeed as the hid seems to be similar for both the devices.

I tried using the wire command and tried copying the serial number of the devices but still the same device was programmed again and again. 

The command I used was

For one

C:\Users\elpk5\Documents\LPCXpresso_7.8.0_426\workspace\i2cTest\Debug\i2cTest.ax
f" -g -2  -vendor=NXP -pLPC824  --wire
\\?\hid#vid_0d28&pid_0204&mi_03#8&22e35216&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}

For another
C:\Users\elpk5\Documents\LPCXpresso_7.8.0_426\workspace\i2cTest\Debug\i2cTest.ax
f" -g -2  -vendor=NXP -pLPC824  --wire \\?\hid#vid_0d28&pid_0204&mi_03#9&350bb73a&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}

Could you give me suggestions if I am making any mistake.
I want to connect both the devices to the same pc simultaneously and program them separately by selecting them individually.

I am attaching some of my screen shots.

Thanks in Advance.

Outcomes