lpcware

dfuApp: Device does not support download

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by jeffaroo on Tue Oct 25 01:34:26 MST 2011
I recently upgraded my LPCXpresso to version 4.1.0 (Windows 7) and soon after I started getting the following error when trying to debug my code.


Quote:
dfuApp: Device does not support download.



I get the same error for all of my LPCXpresso boards.  I installed 4.1.0 on another machine and the boards work fine, so it appears that something is wrong with my v4.1.0 installation on my main machine.  I’ve reinstalled the “USB Device with DFU Capabilities” driver but that did no good.

If I run the following dfuApp command line with an LPC11C24 boarded attached.


Quote:
dfuapp.exe /f LPCXpressoWIN.enc /l log.txt



I get the following output which I can’t decode….


*****************************************************
*** DFU LOG FILE ***
Creation Time : log.txt
*****************************************************


Open Device
Get Device Descriptor successful
Get Configuration Descriptor successful
DFU Get Status successful
---> DFUStatus: No error condition present.
---> DFUState: Device is operating in the DFU mode and is waiting for requests.

Device Descriptor
bLength: 0x12
bDescriptorType: 0x01
bcdUSB: 0x0200
bDeviceClass: 0x00
bDeviceSubClass: 0x00
bDeviceProtocol: 0x00
bMaxPacketSize0: 0x40
idVendor: 0x0471
idProduct: 0xdf55
bcdDevice: 0x0001
iManufacturer: 0x00
iProduct: 0x00
iSerialNumber: 0x00
bNumConfigurations: 0x01
*** END OF FILE ***



Anyone have a clue on what my problem is?

Jeff

Outcomes