lpcware

Debugger gets lost

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by jdurand on Wed Sep 18 17:49:18 MST 2013
I've been using LPCXpresso for quite some time now on a number of projects and it's been working well.  Until now.

I've been writing code for an LPC1113FDB48/302 part for about a month now, debugging has been going fine.  Starting today, when I start stepping into the program, if I step over a routine that accesses the SPI port the disassembly window says "no context" or displays a RAM address and the Debug thread goes away. 

If I run the processor with the debugger connected but not in debug mode, it runs fine.

I've rebooted the computer, restarted LPCXpresso several times.

I just tried setting a break point well past the SPI access and it got there just fine and seems willing to step, so I can continue my debugging.

I'm stumped.

Potentially useful info:
Board of my design (I've designed hundreds of boards, there's no power or noise issues on this), VDD 3.292V (measured).
The SWD pins are not used for anything else, they're connected directly to a header about 1/4" away.
I've been testing the SPI and I2C ports for the past month with no problems. SPI clock = 4.8MHz.
Crystal is 12MHz, default SystemCoreClock of 48MHz.
Using FreeRTOS (I use that in pretty much everything).
LPCXpresso v5.2.4 [Build 2122] [2013-04-29]
Ubuntu Release 12.04 (precise) 32-bit
Kernel Linux 3.2.0-53-generic-pae
GNOME 3.4.2
Memory: 1.9 GiB
Processor: Genuine Intel® CPU 2160 @ 1.80GHz × 2
Available disk space: 200.7 GiB

Outcomes