lpcware

LPC2368 breakpoint ISR issues

Discussion created by lpcware Employee on Jun 15, 2016
Content originally posted in LPCWare by murnesty on Thu Apr 04 23:47:09 MST 2013
I'm doing a FreeRTOS firmware. The program working fine as I want. It is able to
switch task and uip web control. But I fail to debug.

My problem is it will break at a fixed line everytime I click run in debug mode.

I tried
- Delete .metadata folder
- Create a new project and copy all the source files over
- Tried other code on same controller board and is ok. So definitely is caused
by the code.
- Checked *.map file. The heap size is not overflow
- When it pause at the fixed line in debug mode, SP is a valid address.

Symptom
- I program other code which working fine on debug, it is allow to step in, step
over and step out. But with current code, it only allow to step in and step over
but can't step out.
- If I put 2 breakpoints in Red Suite 4, it failed to step over and will
automatically step in instead of step over. This situation happened in this code
and I don't even set a breakpoints.
- In my code, I will beep buzzer twice then only run the actual program. So
weird thing happen is it beep twice in debug mode but beep 4 times in run time.
So I think it will restarts one time once I go into uip task.

I'm using
- Red suite 4
- FreeRTOS v7.4.0
- NXP LPC2368 MCU
- Demo files : ARM7_LPC2368_Eclipse

Outcomes