lpcware

LPCXpresso got wrong, doesn't debug anymore

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Bela on Fri Nov 14 12:49:01 MST 2014
Gentlemen,

I use LPCXpresso v7.5.0 [Build 254] [2014-10-31]  on Ubuntu 14.04 as a novice user.

During debugging my project, I did something wrong (i don't remember already, I wrestled against clearing an IT flag, I still don't know how) and LPCXpresso has fallen into an infinite error message loop. I couldn't click on the OK button so quick, that it could allow me any other operation before the next - same - error message.
I couldn't find any other solution as kill the process by process explorer.
Since than I couldn't debug my project.
I am able to edit my code, I can compile it an I can download it into my LPCXpresso LPC1768 board, but I cannot have my program run down there because these functions are all greyed out. Either F5, F6 or F8 buttons do not have any effect.
I tried everything I can (clean project, creat new project, restart LPCXpresso, reboot my computer) without any effect.
I also tried Window->reset perspective command.

Is there any way to get LPCXpresso back to work again (resetting it somehow), without deleting and than reinstalling it?

I attach a screenshot. Of course, my target is there and attached.

Attachments

Outcomes