lpcware

LPC1830 Xplorer faults immediately on boot

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by gorzelic on Thu Nov 13 22:18:42 MST 2014
Hi,

I recently purchased an 1830 Xplorer and an LPC-Link 2.  I am using the latest version (2.12) of the demo's with latest LPCXpresso (7.5.0).  Demo's build fine and load to SPIFI (switches on board are set to boot from SPIFI), but as soon the reset script runs a hard fault is encountered (listing below). The program always ends up suspended at 0x1a00012e.

I have tried multiple versions of your IDE, multiple versions of the demo's, and several projects from the FreeRTOS site - always starting with a "clean" import into the IDE. The results are always the same.  I have also tried several different SPIFI scripts, and reset scripts.   I can reflash the peripheral test bin that I downloaded and it does boot successfully, but any time I try to debug a project the results are always the same.  From all the manuals I have read over the past few days it seems pretty mindless to get the demos to run, but I have not been successful.  Please suggest next steps - including purchasing a different development board - at this point I need (quickly) anything I can use that has MAC/PHY, preferably with a proven FreeRTOS demo using UDP (which is why I picked the 1830 Xplorer).

Thx,
Stan


LPCXpresso RedlinkMulti Driver v7.5 (Oct 24 2014 22:17:31 - crt_emu_cm_redlink build 172)
(  0) Reading remote configuration
Found chip XML file in C:/Users/Admin/Documents/LPCXpresso_7.5.0_254/workspace/freertos_blinky/Debug/LPC1830.xml
(  5) Remote configuration complete
( 30) Emulator Connected
( 40) Debug Halt
( 50) CPU ID
Emu(0): Conn&Reset. DpID: 2BA01477. CpuID: 410FC230. Info: (null)
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Loaded LPC18_43_S25FL032P.cfx: LPC18/43 S25FL032P 4MB(64KB) SPIFI @0x14000000 (Oct 13 2014 15:52:07)  External Flash Device on SPI
( 65) Chip Setup Complete
Connected: was_reset=false. was_stopped=true
v LPCXpresso Free License - Download limit is 256K
( 70) License Check Complete
( 85) Registered Semihost Handler
(100) Target Ready
Writing 19656 bytes to address 0x14000000 in Flash
(  0) Writing page 0 at 0x14000000 with 19656 bytes
(  0) Page  0 at 14000000
(  0) Page  0 at 14000000: 16384 bytes
( 83) Page  0 at 14004000: 3272 bytes
Erased/Wrote page  0-0 with 19656 bytes in 1732msec
(100) Finished writing Flash successfully.
Flash Write Done
Flash Program Summary: 19656 bytes in 1.73 seconds (11.08 KB/sec)
============= SCRIPT: LPC18LPC43ExternalFLASHBootResetscript.scp =============
Boot from FLASH image pc/sp reset script
PC = 0x1400107D
SP = 0x10018000
XPSR = 0x21000000
VTOR = 0x00000000
============= END SCRIPT =====================================================

Stopped: VectorCatch:HardF (PC unknown: stack=0x10017FE0) (VectorCatch)

Outcomes