lpcware

debug will pause even no breakpoint

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by murnesty on Sun Mar 31 19:13:35 MST 2013
Hi,

  I'm porting a FreeRTOS firmware. It works well on task and it is able to do 2 led blinking tasks. Now I would like to port the uip LAN code. After I port the code, it starts to auto break a specific line. I have search :
http://stackoverflow.com/questions/3441153/eclipse-pausing-without-a-breakpoint

  They say most probably is an exception but I can't check the exception message. I tried both delete the .metadata folder and create a new project but still the same. So I sure is code problem because this happened after I added the uip code.

I'm using :
1) Red suite 4
2) FreeRTOS v7.4.0
3) LPC2368
4) CR-JR ARM7 development kit
http://www.etteam.com/product/ARM/CH_JR_ARM7_LPC2368.htm


I have attached my src code and makefile those. It breaks at portISR.c line 130 : portSAVE_CONTEXT();


Here is the console screen I have:
1) C-Build
**** Build of configuration Debug for project RTOS Sample4 ****

make all
make: Nothing to be done for `all'.


2) MCU Debug Log
(crt_emu_a7_nxp) terminating on communication loss: Pipe has been closed by GDB.
Code Red Technologies Debug Driver v4.0 (Jul 22 2011 23:38:09)
Looked for chip XML file in C:/code_red/RedSuiteNXP_4.0.6_249/redsuite/bin/LPC2368.xml
Looked for vendor directory XML file in C:/code_red/RedSuiteNXP_4.0.6_249/redsuite/bin/nxp_directory.xml
Found generic directory XML file in C:/code_red/RedSuiteNXP_4.0.6_249/redsuite/bin/crt_directory.xml
Emu(0): Conn&Reset. DpID: 4F1F0F0F. Info: T1S6RGRIA
JTAG Frequency: 250 KHz. RTCK: False. Vector catch: False.
Packet delay: 0  Poll delay: 0.
NXP: LPC2368  Part ID: 0x1600F925
Connected: was_reset=false. was_stopped=true
v Full license with download limit of 512K
Writing 65808 bytes to 0000 in Flash (assumed clock: 48.0MHz)
Verified-same page 0-7 with 32768 bytes in 2410msec
Verified-same page   8 with 32768 bytes in 2426msec
Verified-same page   9 with 272 bytes in 66msec
Flash write Done
Stopped
Stopped: Breakpoint #1
Stopped: Step


3) Debug arm-none-eobi-gdb
set remotetimeout 60000
info program
Debugging a target over a serial line.
Program stopped at 0xffffffec.
Type "info stack" or "info registers" for more information.
set mem inaccessible-by-default off
mon ondisconnect cont
Note: automatically using hardware breakpoints for read-only addresses.


4) Debug *.axf
[no msg]

Outcomes