lpcware

LPCXpresso can not debug a custom LPC1768 board while Keil uVision can

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by zhiyong on Fri Sep 05 02:16:02 MST 2014
Hi all,

First post in this forum so greetings to everyone.

I am having some trouble debugging a custom board I made with LPCXpresso, hopefully someone could lend me a hand.

The board is made off MBED, Jtag interface was designed based on the following page
http://www.lpcware.com/content/faq/lpcxpresso/debug-design

Power supply is sourced from an on board step down IC.

The program I was trying to debug is a simple blinky exported from mbed.org.

Somehow, the debug process just could not proceed. I have tried LPCXpresso  from version 6.1 to 7.3, with both ULink2 and LPC-link2 debug tool, and 10 pin cable.

The most error message I got was:

Error in final launch sequence

Other error message are:
10: Could not start execution from stop
2: Target marked as non-debugable.

The funny thing is,  the same setup (ulink2 / LPC-link2 + my custom board) works perfectly fine with Keil uVision. So the board itself and debug tools work.

I tend to think I may have missed some configuration in LPCXpresso but could figure out what exactly I am missing. I tried changing Vector catch, reset handling etc, none of them worked.

So that is the situation, any thoughts ideas will be greatly appreciated.

Outcomes