lpcware

Trouble trying to implement SPIFI library

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by Alaric on Wed Feb 03 23:40:51 MST 2016
Hi,
I'm trying to use the latest "spifilib_m3" V1.03 library on our lpc1830, with a S25FL128S dataflash, using the latest lpcxpresso V8.
We want to use the dataflash for code execution (XIP) and data storage. The board that I am working on currently works perfectly with our Keil project using one of the first spifi libraries implementations.

I've followed the app note on how to relocate a library to RAM using the linkerscripts (https://www.lpcware.com/content/faq/lpcxpresso/relocating-code-flash-ram) but I still get a Hardfault condition when i run/debug the code.

I've looked at the map file and it shows that there are some "static const" like ".rodata.spifiCmdOp" and ".rodata.pData" which still reside in .text region which is address 0x1400 xxxx which I think is causing the problem.

I've included my test projects and would appreciate any help or suggestions.

Thanks,
Alaric

Original Attachment has been moved to: workspace.zip

Outcomes